Go Back   Web User Forums > Internet Access > Broadband help and advice

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 23-05-18, 06:38
donnyboy36 donnyboy36 is offline
Familiar face
 
Join Date: Mar 2015
Posts: 55
Default Ethernet connection on Medion desktop

Problem arisen last few days, previously all OK.
Windows 7, Plusnet, (their Sagemcom router)
Pathetically slow connecting to internet & video streaming sites like BBC Iplayer etc stuttering, stopping & buffering.
Have tried different cables & used different router sockets.
No problems with laptop, tablet & mobile connecting via WiFi.
No problem connecting laptop with ethernet cable (disabling WiFi) download speed of 2.7 Mbps, upload of 0.9.
Suspect problem is within desktop.
Any suggestions.
Many thanks.
Reply With Quote
  #2  
Old 23-05-18, 09:01
Cantrel Cantrel is offline
Global Moderator
 
Join Date: Jul 2012
Location: UK
Posts: 10,855
Default Re: Ethernet connection on Medion desktop

Do you have any other devices connected when streaming from iPlayer as this will pull down the bandwidth.

I think I read once on the iPlayer site that to get a smooth connection, the min requirement was 3.7Mbps but if you have previously managed with 2.7 then that's okay.

Which antivirus program are you using and have you tried in Safe Mode with Networking to see if there's any improvement and have you installed anything prior to this problem ?

Reinstalling the Ethernet adapter driver can sometimes help which you can do by going Start - type devmgmt.msc and press enter when it comes up.

In Device Manager click on View/Show hidden devices and expand Network adapters.

Right click on the Ethernet one and select Uninstall but do not check the box to include software.

In the top menu click on Action/Scan for hardware changes where it will reinstate, or simply close Device Manager and reboot.

Go Start - type cmd then right click on cmd and select Run as administrator - accept the UAC and enter these cmds - not sure if they will help but they won't harm.

netsh winsock reset catalog

netsh int ip reset resetlog.txt

shutdown /r /t 00

and then see how things are after the reboot.

Even though all other devices are working fine, power cycling the router can resolve connectivity problems on another machine.

To perform a power cycle, switch off the router and computer(s) and disconnect all cables for about 2 minutes.

Reconnect the cables and switch just the router on and when all of its lights are back on, switch just the affected machine on and check its performance.
Reply With Quote
  #3  
Old 23-05-18, 20:54
donnyboy36 donnyboy36 is offline
Familiar face
 
Join Date: Mar 2015
Posts: 55
Default Re: Ethernet connection on Medion desktop

Hi Cantrel, thanks for your input.
Am running Avast Free Antivirus.
Have tried Safe mode with Networking - no different,
Trying Re-installing the network adaptor but cmd Run as administrator
doesn't work in Windows 7 & the other commands you suggest must have
administrator privileges to run. How can I do this in Windows 7 ?
Forgot to mention previously that the internet & Eth1 lights on router are
flashing furiously all the time. Downloading or Uploading something even when I am not doing anything on net.
Your help is much appreciated as always.
Reply With Quote
  #4  
Old 23-05-18, 21:12
Cantrel Cantrel is offline
Global Moderator
 
Join Date: Jul 2012
Location: UK
Posts: 10,855
Default Re: Ethernet connection on Medion desktop

On my Win 7 machine that works for the cmd prompt to run it as an admin.

Try it this way - go Start - All Programs - scroll down to and expand Accessories then right click on Command Prompt and select Run as administrator.

However, to check if you have that option when you right click, right click on any of your desktop icons.

If you don't have that option in your right click context menu, this article will help you to restore it -

https://www.sevenforums.com/tutorial...ndows-7-a.html

The lights will flash all of the time while you have a computer switched on.

You haven't said if you tried the router power cycle.
Reply With Quote
  #5  
Old 24-05-18, 14:43
donnyboy36 donnyboy36 is offline
Familiar face
 
Join Date: Mar 2015
Posts: 55
Default Re: Ethernet connection on Medion desktop

Hi Cantrel.
I ran
netsh winsock reset catalog
netsh int ip reset resetlog.txt
shutdown /r /t 00
as administrator as you suggested - no difference.
Sorry I didn't mention that i also tried the router power cycle - again no difference.
I've checked for updates on - Realtek PCIe FE Family Controller, which I assume to be the Ethernet adaptor, but there do not appear to be any.
Re-installing the adaptor as previously suggested didn't make any difference either.
It would appear to me that the problem lies in the Ethernet adaptor on my Desktop, as my laptop (Windows 10) connected to router by ethernet works perfectly.
I'm wondering if I should get a WiFi dongle & dispense with Ethernet altogether.
What do you think.
Regardds.
Don.
Reply With Quote
  #6  
Old 24-05-18, 15:23
Cantrel Cantrel is offline
Global Moderator
 
Join Date: Jul 2012
Location: UK
Posts: 10,855
Default Re: Ethernet connection on Medion desktop

On an older Win 7 laptop I was getting poor speeds from the fitted Realtek wireless adapter so I took it in to a repair shop and got them to swap it for something else.

They stuck an Intel one in and that produced much better wireless speeds.

That could be your solution for the Ethernet adapter, but I think it would be a case of suck it and see as it was for me.

Wireless dongle speeds aren't very good anyway as I've seen reported.
Reply With Quote
  #7  
Old 24-05-18, 18:28
donnyboy36 donnyboy36 is offline
Familiar face
 
Join Date: Mar 2015
Posts: 55
Default Re: Ethernet connection on Medion desktop

As always Cantrel, Many thanks for your help.
I'll keep plodding on & see what happens.
Regards.
Don
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Search the forum

Search

© Dennis Publishing Limited Licensed by Felden





All times are GMT. The time now is 23:39.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright Dennis Publishing 2010, All rights reserved